search  
American Red Cross

Update Your Web Browser

While CAN continues to support a broad range of older browsers, users will enjoy increased security and performance by updating to recent versions of whichever browser you use. The following browsers are recommended:

  • Internet Explorer 7.x (Windows XP, Vista and Windows 7)
  • Internet Explorer 8.x (Windows XP, Vista and Windows 7)
  • Firefox 3.x (Mac OS 10.4 and higher, Windows XP, Vista and Windows 7)

CAN Recovery Tools are not currently supported on Netscape, Opera, Safari, Chrome or Internet Explorer 6.x Web browsers. Additionally, accessing any of the tools from an iPad, iPhone or other mobile devices is not supported.